Privy Outage

Incident Report for Flaunch

Resolved

Privy fixed the issue, usual usage service has resumed.
Posted Oct 21, 2025 - 08:00 UTC

Investigating

Privy is currently experiencing issues and is working on a fix.

In the meantime you can trade tokens directly on Uniswap or Matcha.
Posted Oct 20, 2025 - 15:15 UTC
This incident affected: Flaunch Website.