Cloudflare Global Outage

Incident Report for Flaunch

Resolved

CLoudflare solved the issue.
Posted Nov 18, 2025 - 21:00 UTC

Investigating

We are currently investigating this issue.
Posted Nov 18, 2025 - 12:30 UTC
This incident affected: Flaunch Website and Flaunch API.